Back to overview
Degraded

Payments via Stripe are degraded

Mar 21 at 12:45pm GMT
Affected services
Payments

Resolved
Mar 21 at 03:07pm GMT

The fix has been rolled out and payments are working as normal now.

Created
Mar 21 at 12:45pm GMT

Payments via Stripe are failing for a subset of customers due to an issue with our authentication provider. The root cause has been identified and we will share further updates once fixed.