Back to overview
Downtime

Dashboard unavailable

Jun 26 at 07:22am BST
Affected services
Dashboard

Resolved
Jun 26 at 08:01am BST

Our authentication provider have resolved the issues impacting the dashboard.

Created
Jun 26 at 07:22am BST

Our dashboard is currently unavailable as our authentication provider is experiencing downtime. Customer facing flows and our API are unaffected.